Advisories ยป MGASA-2014-0124

Updated mediawiki packages fix multiple vulnerabilities

Publication date: 07 Mar 2014
Type: security
Affected Mageia releases : 3 , 4
CVE: CVE-2014-2242 , CVE-2014-2243 , CVE-2014-2244


Updated mediawiki packages fix security vulnerabilities:

MediaWiki before 1.22.3 does not block unsafe namespaces, such as a W3C XHTML
namespace, in uploaded SVG files.  Some client software may use these
namespaces in a way that results in XSS.  This was fixed by disallowing
uploading SVG files using non-whitelisted namespaces (CVE-2014-2242).

MediaWiki before 1.22.3 performs token comparison that may be vulnerable to
timing attacks.  This was fixed by making token comparison use constant time

MediaWiki before 1.22.3 could allow an attacker to perform XSS attacks, due
to flaw with link handling in api.php.  This was fixed such that it won't
find links in the middle of api.php links (CVE-2014-2244).