Advisories ยป MGASA-2021-0372

Updated nodejs packages fix security vulnerabilities

Publication date: 25 Jul 2021
Type: security
Affected Mageia releases : 8
CVE: CVE-2020-7774 , CVE-2021-23362 , CVE-2021-27290


This affects the package y18n before 3.2.2, 4.0.1 and 5.0.5. PoC by po6ix:
const y18n = require('y18n')();
y18n.setLocale('__proto__'); y18n.updateLocale({polluted: true});
console.log(polluted); // true (CVE-2020-7774).

The package hosted-git-info before 3.0.8 are vulnerable to Regular Expression
Denial of Service (ReDoS) via regular expression shortcutMatch in the fromUrl
function in index.js. The affected regular expression exhibits polynomial
worst-case time complexity (CVE-2021-23362).

ssri 5.2.2-8.0.0, fixed in 8.0.1, processes SRIs using a regular expression
which is vulnerable to a denial of service. Malicious SRIs could take an
extremely long time to process, leading to denial of service. This issue only
affects consumers using the strict option (CVE-2021-27290).

Theses issues are fixed by upgrading nodejs packages to latest available
LTS 14.17.3 version. See upstream releases notes for other included bugfixes.