Advisories ยป MGASA-2020-0248

Updated cups packages fix security vulnerability

Publication date: 10 Jun 2020
Type: security
Affected Mageia releases : 7
CVE: CVE-2019-8842 , CVE-2020-3898 , CVE-2019-8696 , CVE-2019-8675 , CVE-2019-2228

Description

Updated cups packages fix security vulnerabilities:

It was discovered that CUPS incorrectly handled certain language values.
A local attacker could possibly use this issue to cause CUPS to crash,
leading to a denial of service, or possibly obtain sensitive information
(CVE-2019-2228).

Stephan Zeisberg discovered that the CUPS SNMP backend incorrectly
handled encoded ASN.1 inputs. A remote attacker could possibly use this
issue to cause CUPS to crash by providing specially crafted network
traffic (CVE-2019-8675, CVE-2019-8696).

The ippReadIO function may under-read an extension (CVE-2019-8842).

Stephan Zeisberg discovered that CUPS incorrectly handled certain
malformed ppd files. A local attacker could possibly use this issue to
execute arbitrary code (CVE-2020-3898).

The cups package has been updated to version 2.2.13 and patched to fix
these issues and other bugs.

Also, this update will hopefully fix the cups service failing to start at
boot on some systems. 
                

References

SRPMS

7/core