Advisories ยป MGASA-2020-0246

Updated sudo packages fix security vulnerability

Publication date: 10 Jun 2020
Type: security
Affected Mageia releases : 7
CVE: CVE-2019-19232 , CVE-2019-19233 , CVE-2019-19234

Description

Updated sudo packages fix security vulnerabilities:

It was found that sudo always allowed commands to be run with unknown
user or group ids if the sudo configuration allowed it for example via
the "ALL" alias. This could allow sudo to impersonate non-existent
account and depending on how applications are configured, could lead to
certain restriction bypass. This is now explicitly disabled. A new
setting called "allow_unknown_runas_id" was introduced in order to enable
this (CVE-2019-19232).

When an account is disabled via the shadow file, by replacing the
password hash with "!", it is not considered disabled by sudo. And
depending on the configuration, sudo can be run by using such disabled
account (CVE-2019-19234).

The sudo package has been updated to version 1.8.31p1, fixing these
issues and other bugs.
                

References

SRPMS

7/core