Advisories ยป MGASA-2019-0233

Updated vlc packages fixes security vulnerabilities

Publication date: 31 Aug 2019
Type: security
Affected Mageia releases : 6 , 7
CVE: CVE-2019-13602 , CVE-2019-13962 , CVE-2019-14437 , CVE-2019-14438 , CVE-2019-14498 , CVE-2019-14533 , CVE-2019-14534 , CVE-2019-14535 , CVE-2019-14776 , CVE-2019-14777 , CVE-2019-14778 , CVE-2019-14970

Description

Updated vlc packages fixes security vulnerabilities:

Multiple security issues were discovered in the VLC media player, which
could result in the execution of arbitrary code or denial of service if
a malformed file/stream is processed (CVE-2019-13602, CVE-2019-13962,
CVE-2019-14437, CVE-2019-14438, CVE-2019-14498, CVE-2019-14533,
CVE-2019-14534, CVE-2019-14535, CVE-2019-14776, CVE-2019-14777,
CVE-2019-14778, CVE-2019-14970).

The vlc package has been updated to version 3.0.8, fixing these issues and
other bugs.  In Mageia 6, the libebml package has been updated to version
1.3.7, which is needed for Matroska support.
                

References

SRPMS

7/tainted

7/core

6/tainted

6/core