Advisories ยป MGASA-2017-0309

Updated kernel-linus packages fixes security and other bugs

Publication date: 25 Aug 2017
Type: security
Affected Mageia releases : 5
CVE: CVE-2017-10663 , CVE-2017-1000112

Description

This kernel-linus update is based on upstream 4.4.82 and fixes atleast the
following security issues:

The curseg->segno call in f2fs driver can be malformed so that it will have
a value that triggers an out of boundary write that could cause memory
corruption on the affected devices, leading to code execution in the kernel
context. This would allow for more data to be accessed and controlled by
the malware (CVE-2017-10663).

The UDP Fragmentation Offload (UFO) feature is vulnerable to out-of-bounds
writes causing exploitable memory corruption. If unprivileged user
namespaces are available, this bug can be exploited to gain root privileges
(CVE-2017-1000112).

For other upstream fixes in this update, read the referenced changelogs.
                

References

SRPMS

5/core