Updated postgresql package fixes security vulnerabilityPublication date: 01 Jul 2015
Affected Mageia releases : 4
CVE: CVE-2015-3165 , CVE-2015-3166 , CVE-2015-3167
Double free vulnerability in PostgreSQL before 9.0.20, 9.1.x before 9.1.16, 9.2.x before 9.2.11, 9.3.x before 9.3.7, and 9.4.x before 9.4.2 allows remote attackers to cause a denial of service (crash) by closing an SSL session at a time when the authentication timeout will expire during the session shutdown sequence (CVE-2015-3165). The replacement implementation of snprintf() failed to check for errors reported by the underlying system library calls; the main case that might be missed is out-of-memory situations. In the worst case this might lead to information exposure (CVE-2015-3166). In contrib/pgcrypto, some cases of decryption with an incorrect key could report other error message texts, possibly leading to a side-channel key exposure (CVE-2015-3167). The postgresql9.0, postgresql9.1, postgresql9.2, and postgresql9.3 packages have been updated to versions 9.0.22, 9.1.18, 9.2.13, and 9.3.9, respectively, fixing these issues, as well as some data corruption issues. See the upstream release notes for more details.