Advisories ยป MGASA-2018-0379

Updated unixODBC packages fix security vulnerability

Publication date: 21 Sep 2018
Type: security
Affected Mageia releases : 6
CVE: CVE-2018-7409 , CVE-2018-7485

Description

unixODBC before version 2.3.5 is vulnerable to a buffer overflow in the
DriverManager/__info.c:unicode_to_ansi_copy() method. An attacker could
exploit this to cause a denial of service or other unspecified impact
(CVE-2018-7409).

The SQLWriteFileDSN function in odbcinst/SQLWriteFileDSN.c in unixODBC
2.3.5 has strncpy arguments in the wrong order, which allows attackers to
cause a denial of service or possibly have unspecified other impact
(CVE-2018-7485).
                

References

SRPMS

6/core