Advisories ยป MGASA-2014-0393

Updated bash packages fix CVE-2014-7169

Publication date: 28 Sep 2014
Type: security
Affected Mageia releases : 3 , 4
CVE: CVE-2014-7169

Description

Updated bash packages fix security vulnerability:

It was found that the fix for CVE-2014-6271 was incomplete, and Bash still
allowed certain characters to be injected into other environments via
specially crafted environment variables. An attacker could potentially use
this flaw to override or bypass environment restrictions to execute shell
commands. Certain services and applications allow remote unauthenticated
attackers to provide environment variables, allowing them to exploit this
issue (CVE-2014-7169).

Bash has been updated to version 4.2 patch level 49 to fix this issue.
                

References

SRPMS

3/core

4/core