Advisories ยป MGASA-2014-0279

Updated samba packages fix multiple vulnerabilities

Publication date: 04 Jul 2014
Type: security
Affected Mageia releases : 3 , 4
CVE: CVE-2014-0178 , CVE-2014-0244 , CVE-2014-3493


Updated samba packages fix security vulnerabilities:

Information leak vulnerability in the VFS code, allowing an authenticated
user to retrieve eight bytes of uninitialized memory when shadow copy is
enabled (CVE-2014-0178).

Samba versions before 3.6.24, 4.0.19, and 4.1.9 are vulnerable to a denial
of service on the nmbd NetBIOS name services daemon. A malformed packet
can cause the nmbd server to loop the CPU and prevent any further NetBIOS
name service (CVE-2014-0244).

Samba versions before 3.6.24, 4.0.19, and 4.1.9 are affected by a denial
of service crash involving overwriting memory on an authenticated
connection to the smbd file server (CVE-2014-3493).