Advisories ยป MGASA-2014-0247

Updated libtasn1 packages fix CVE-2014-3467-9

Publication date: 02 Jun 2014
Type: security
Affected Mageia releases : 3 , 4
CVE: CVE-2014-3467 , CVE-2014-3468 , CVE-2014-3469


Updated libtasn1 packages fix security vulnerabilities:

Multiple buffer boundary check issues were discovered in libtasn1 library,
causing it to read beyond the boundary of an allocated buffer.  An untrusted
ASN.1 input could cause an application using the library to crash

It was discovered that libtasn1 library function asn1_get_bit_der() could
incorrectly report negative bit length of the value read from ASN.1 input.
This could possibly lead to an out of bounds access in an application using
libtasn1, for example in case if application tried to terminate read value
with NUL byte (CVE-2014-3468).

A NULL pointer dereference flaw was found in libtasn1's
asn1_read_value_type() / asn1_read_value() function. If an application
called the function with a NULL value for an ivalue argument to determine
the amount of memory needed to store data to be read from the ASN.1 input,
libtasn1 could incorrectly attempt to dereference the NULL pointer, causing
an application using the library to crash (CVE-2014-3469).