Advisories ยป MGASA-2014-0036

Updated Firefox & Thunderbird packages fix multiple security vulnerabilities

Publication date: 06 Feb 2014
Type: security
Affected Mageia releases : 3 , 4
CVE: CVE-2014-1477 , CVE-2014-1479 , CVE-2014-1481 , CVE-2014-1482 , CVE-2014-1486 , CVE-2014-1487


Updated firefox and thunderbird packages fix security vulnerabilities:

Several flaws were found in the processing of malformed web content. A web
page containing malicious content could cause Firefox or Thunderbird to
crash or, potentially, execute arbitrary code with the privileges of the
user running it (CVE-2014-1477, CVE-2014-1482, CVE-2014-1486).

A flaw was found in the way Firefox and Thunderbird handled error messages
related to web workers. An attacker could use this flaw to bypass the
same-origin policy, which could lead to cross-site scripting (XSS) attacks,
or could potentially be used to gather authentication tokens and other data
from third-party websites (CVE-2014-1487).

A flaw was found in the implementation of System Only Wrappers (SOW).
An attacker could use this flaw to crash Firefox or Thunderbird. When
combined with other vulnerabilities, this flaw could have additional
security implications (CVE-2014-1479).

It was found that the Firefox and Thunderbird JavaScript engine incorrectly
handled window objects. A remote attacker could use this flaw to bypass
certain security checks and possibly execute arbitrary code (CVE-2014-1481).